About the Application Window

The dsClient Desktop application window provides the standard window controls (minimize, maximize/restore, close, move, etc.) and a menu bar. The application version is displayed in the window's title bar. The window is divided into three main sections:

Explorer Panel - contains the Library Browser

Messenger Panel - contains the Validation Errors panel, the Notifications panel, the application's Log console, and the Help panel

Desktop Panel - the screens for the various objects with which you will be working are displayed in this panel

Menu Options

File Menu

New - create a new XML configuration. Choose from one of the following:

Workspace - create a complete test configuration that can be transmitted to dsTest or used to generate an XML document for automated testing

OM Report - create a new Operational Measurement report in either graph or tabular format

Nodes - create a snippet of the specified type of node emulator

Snippets allow you to define partial configurations that you can then link into any number of test configurations. You can configure an interface snippet, for example, with an IP address that is valid for a particular platform and use that snippet in the test configurations that will run on that platform. You can learn more about snippets here.

Interfaces - create a snippet for a physical interface configuration

Subscriber Database - create a subscriber database snippet

Profiles - create a snippet of the specified type of subscriber profile

SmartProfile Component - create a snippet of the specified component type

Diameter Application Dictionary - create a User Dictionary to validate incoming Diameter Messages

Open... - opens an XML Library browser where you can select a saved Workspace, OM report, or snippet configuration to open

Recent Files - displays a list of the five most recently opened files; select a file to open

Compare To... - compare two XML configurations to see the structural differences between the two configurations and optionally merge content from one into another

Import... - import an XML document into your library

Export... - create and export a bundle of files from your library

Search... - search a CDR Database or Subscriber Event Log

Preferences... - set preferences for application display, reports, default file system locations, etc.

Exit - closes the application as does closing the application window

Servers Menu

Organize... - opens the Server List screen where you can define your servers, set server accessibility, and refresh the server cache

Manage... - select Manage Locks... to manage accessibility to your servers or select a server to open the Status and Operations screen where you can manage a particular dsTest installation, access utilities that run separately from dsTest, and interact directly with dsTest

Window Menu

Toolbars - allows you to toggle the visibility of the Explorer and Messenger toolbars.

View - allows you to toggle the visibility of one of the Explorer or Messenger tabs.

Window list - lists the windows open in the desktop panel. Selecting a window brings it to the front of the stack. Not available when desktop tabs are used instead of floating windows.

Help Menu

About... - displays current application data including memory used

Online Help - attempts to open this documentation in your default browser. Internet connectivity is required.

Sliding Panels

While they display different content, the two panels mentioned above, the Explorer Panel and the Messenger Panel, both operate in the same way. You can display either panel in persistent mode by clicking the restore icon () from the relevant panel's toolbar. When a panel is displayed in persistent mode you can hide it by clicking the minimize () icon in the upper right corner of the panel. You can also display one of the tabs from either panel in transitory mode by clicking its icon in the panel's toolbar or by selecting the tab from the Window>View menu. In this case you can hide the entire panel by pressing the Esc key or remove a tab via the Window>View menu and the panel will collapse after the last tab is removed.

You can change the width or height, depending on the panel, by positioning your mouse over the right or top edge of the panel until the cursor changes to a bi-directional arrow () and then clicking the left mouse button and dragging to the desired position.

The Explorer Panel

The Explorer Panel, docked to the left side of the application window, contains the Library Explorer tab which you can open in transitory mode with the folder icon () or the Window>View>XML Library selection. Refer to About the XML Library for more information about the Library Explorer.

The Messenger Panel

The Messenger Panel is docked at the bottom of the application window, and it contains the tabs explained below.

Validation Errors

The Errors tab displays any validation errors that exist in the configuration files that are currently open in the Desktop Panel.

Errors are reported as they occur during editing or as they are encountered while parsing a saved file, and those errors are cleared as they are corrected. Error messages are grouped by file/screen and a group may be hidden or shown with the +/- button. Each error is displayed with the following information:

Source Element - the name of the element that generated the error

Parent Element - the immediate parent of the Source Element (if no Parent Element is shown, the Source Element is at the top level of the XML structure)

Error - the error message, typically regarding a missing or otherwise invalid element or attribute value

Errors are indicated within the Workspace screen with a red exclamation point (!) placed next to the value field and with red text in the field's label and the associated tree node's label. You can use the F3 key to easily navigate to the source of an error.

Server Notifications

With this panel you can both manage and view the notifications dsTest will generate during test or application operations. See the Server Notifications topic for more information.

Application Log

The Log tab displays the log messages that have been recorded during the current application session. You can also change the log level using the selection lists provided and clear the display by clicking . Clearing messages only affects the displayed log - the log file will retain all messages. Changing the log level, however, affects both the displayed log and the log file and that level will remain in effect through the end of the session unless you change it again.

Log levels are inclusive - that is, the level selected includes messages of that level and of all levels above. Error messages are color-coded for severity. The following log levels are available:

Off - logging is disabled.

Severe - adds SEVERE messages that record unrecoverable errors.

Warning - adds WARNING messages that record errors that were encountered but handled or that highlight undesirable conditions.

Informational (default) - adds INFO messages that record major actions or events (e.g., file operations, command transaction processing, initialization events).

Trace - adds COMM messages that print the content of all communications, incoming and outgoing, with dsTest.

Debug - adds DEBUG messages that trace all operations of dsClient.

You can set the level of all types of logging, or set the level of each individual type: Configuration/Command Framework, OM Framework, Server Communications, XML Library Management, Database Framework, Interactive Fields, or Application Infrastructure.

Unless instructed otherwise by our Support Team you should not alter the default log settings.

Schema Help

The Help panel displays the Online Help for the active Workspace element or attribute (i.e. the field or tree node that has the current focus). Unlike the other Messenger tabs, this tab can only be displayed by pressing the F1 key and is always hidden by pressing the Esc key.